股票公式:优化MACD精确控盘,股票知识,股票入门,炒股入门

更多>> 股票入门

股票公式:优化MACD精确控盘

  股票公式:优化MACD精确控盘。下面杰克文为你介绍股票公式:优化MACD精确控盘。

  {SHORT=26,LONG=12,M=9,P1=19,P2=120,K= -40,G=-26}

  stickline(c》0,-1,1,6,0),color330066;

  DIF:=((EMA(CLOSE,SHORT)-EMA(CLOSE,LONG)))*-1;

  DEA:=EMA(DIF,M),COLORFF00FF;

  MACD:=2*(DIF-DEA);

  HH:=MA(CLOSE,10);

  GG:=MA(CLOSE,12);

  上:=ema((MA(HIGH,3) * 1.05),30);

  下:=ema((MA(LOW,3) * 0.96),30);

  决战:STICKLINE((((CROSS(DIF,DEA) AND ((下 - REF(下,1)) 》 0)) AND (MACD 》= REF(MACD,1))) AND (DIF 《 0)),DIF,0.4,3,0),color0000FF;

  DRAWICON((((CROSS(DIF,DEA) AND ((下 - REF(下,1)) 》 0)) AND (MACD 》= REF(MACD,1))) AND (DIF 《 0)),0.4,0);

  DRAWTEXT((((CROSS(DIF,DEA) AND ((下 - REF(下,1)) 》 0)) AND (MACD 》= REF(MACD,1))) AND (DIF 《= 0)),0.4,‘DIFF金叉’),color0000FF;

  STICKLINE(FILTER(((((MACD 》= REF(MACD,5)) AND ((下 - REF(下,1)) 》 0)) AND (MACD 《= 0)) AND ((GG - REF(GG,1)) 》= 0)),3),0,0.5,3,0),color00FF00;

  DRAWICON(FILTER(((((MACD 》= REF(MACD,5)) AND ((下 - REF(下,1)) 》 0)) AND (MACD 《= 0)) AND ((GG - REF(GG,1)) 》= 0)),3),0.5,0);

  DRAWTEXT(FILTER(((((MACD 》= REF(MACD,5)) AND ((下 - REF(下,1)) 》 0)) AND (MACD 《= 0)) AND ((GG - REF(GG,1)) 》= 0)),3),0.5,‘绝佳买入’),color00FF00;

  VCF1:=LLV(LOW,5);

  VCF2:=HHV(HIGH,5);

  VCF3:=EMA((((CLOSE - VCF1) / (VCF2 - VCF1)) * 100),4);

  VCF4:=EMA(((0.667 * REF(VCF3,1)) + (0.333 * VCF3)),2);

  VCF5:=((HIGH + LOW) / 2);

  VCF6:=DMA(VCF5,(VOL / SUM(VOL,5)));

  VCF7:=DMA(VCF5,(VOL / SUM(VOL,13)));

  VCF8:=DMA(VCF5,(VOL / SUM(VOL,34)));

  VCF9:=DMA(VCF5,(VOL / SUM(VOL,75)));

  VCFA:=EMA(WINNER((0.9 * CLOSE)),5);

  VCFB:=(1 - EMA(WINNER((1.2 * CLOSE)),5));

  VCFC:=EMA(WINNER(CLOSE),5);

  VCFD:=((100 * (CLOSE - VCF6)) / VCF6);

  VCFE:=((100 * (CLOSE - VCF7)) / VCF7);

  VCFF:=((100 * (MIN(CLOSE,OPEN) - VCF8)) / VCF8);

  VCF10:=BARSLAST(((VCF8 》 VCF9) AND (REF(VCF8,1) 《= REF(VCF9,1))));

  VCF11:=((((COUNT(((WINNER(CLOSE) 《 0.11) AND (EMA(WINNER(CLOSE),5) 《 0.15)),2) 》 0) OR (((1 - WINNER((1.2 * CLOSE))) 》= 0.8) AND (WINNER(CLOSE) 《 0.05))) AND (COUNT((VCFE 《 (0 - 16)),2) 》 0)) AND (COUNT((VCFF 《 (0 - 20)),2) 》 0));

  VCF12:=((((COUNT((VCFD 《 (0 - 10)),2) 》 0) AND (COUNT((VCFE 《 (0 - 15)),2) 》 0)) AND (COUNT((VCFF 《 (0 - 15)),2) 》 0)) AND (COUNT((VCFA 》 0.8),VCF10) = 0));

  VCF13:=(((COUNT((VCF11 OR VCF12),2) 》 0) AND (VCF3 》 REF(VCF3,1))) AND (((1 - WINNER((1.15 * CLOSE))) * 100) 》 80));

  出击1:=IF((VCF13 AND (COUNT(VCF13,3) 《= 1)),0.1,0);

  黑马出击:IF((VCF13 AND (COUNT(VCF13,3) 《= 1)),0.37,0),LINETHICK3,color0000FF;

  DRAWICON((黑马出击 》 0),0.37,1);

  DRAWTEXT((黑马出击 》 0),0.35,‘★黑马’),colorFFFFFF;

  DRAWTEXT((黑马出击 》 0),0.35,‘出击’),color00FF00;

  VAR26:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);

  VAR27:=((EMA(CLOSE,12) - EMA(CLOSE,26)) * 100);

  VAR28:=EMA(VAR27,9);

  VAR29:=(2 * (VAR27 - VAR28));

  STICKLINE(((VAR27 《 (0 - 50)) AND (VAR26 》 7)),0,(0 - 0.1),5,0),color0000FF;

  DRAWTEXT((((VAR27 《 (0 - 50)) AND (VAR26 》 7)) AND (VAR27 《 VAR28)),(0 - 0.09),‘底’),colorFFFFFF;

  DRAWTEXT((((VAR27 《 (0 - 50)) AND (VAR26 》 7)) AND (VAR27 》= VAR28)),(0 - 0.1),‘追’),colorFFFFFF;

  VAR1:=1;

  VAR2:=MA(CLOSE,18);

  VAR3:=(((CLOSE - VAR2) / VAR2) * 100);

  VAR4:=MA(VAR3,1);

  升跌:=(VAR4 * VAR1);

  VAR5:=BARSLAST((CROSS((0 - 10),VAR4) = 1));

  VAR6:=BARSLAST((CROSS(VAR4,10) = 1));

  VAR7:=((VAR4 《 (0 - 10)) AND (VAR5 》= 5));

  VAR8:=((VAR4 》 10) AND (VAR6 》= 5));

  {C1:(0.01 * (IF(((VAR4 《 (0 - 10)) AND (VAR5 》= 5)),VAR4,0) * VAR1)),LINETHICK1,color0000FF;

  C2:=C1;}

  C3:=(IF(((VAR4 》 10) AND (VAR6 》= 5)),VAR4,0) * VAR1);

  C4:=C3;

  D1:=((((升跌 》 REF(升跌,1)) AND VAR7) * 0.2) * VAR1);

  中期底部:=LLV(CLOSE,30);

  D:(FILTER(((((((升跌 》 REF(升跌,1)) AND (LOW 《= 中期底部)) AND (CLOSE 》 中期底部)) AND VAR7) * 0.5) * VAR1),3) * 0.5),LINETHICK2,color0000FF;

  DRAWTEXT((D 》= 0.25),D,‘★铁底’),color00FFFF;

  STICKLINE(((CROSS(MACD,DIF) AND (MACD 》= (0 - 0.05))) AND (MACD 《= 0.02)),MACD,0.23,0,0),LINETHICK2,color00FFFF;

  DRAWTEXT(((CROSS(MACD,DIF) AND (MACD 》= (0 - 0.05))) AND (MACD 《= 0.02)),0.23,‘^MACD’),color0000FF;

  DRAWTEXT(((CROSS(MACD,DIF) AND (MACD 》= (0 - 0.05))) AND (MACD 《= 0.02)),0.23,‘金叉’),LINETHICK4,colorFFFFFF;

  DRAWICON(((CROSS(MACD,DIF) AND (MACD 》= (0 - 0.05))) AND (MACD 《= 0.02)),0.23,1);

  DIFF2:=(EMA(CLOSE,2) - EMA(OPEN,5));

  操盘手:=DIFF2;

  (0.4 * ((CROSS(操盘手,MACD) AND (MACD 《= (0 - 0.11))) AND (LOW 《= 下))),LINETHICK2,colorFFFFFF;

  DRAWTEXT(((CROSS(操盘手,MACD) AND (LOW 《= 下)) AND (MACD 《= (0 - 0.11))),0.6,‘短线5%’),colorB7D16F;

  MA1:=MA(CLOSE,5);

  MA2:=MA(CLOSE,10);

  BB:(0.7 * ((((((CROSS(DIF,DEA) AND (CLOSE 《 上)) AND ((下 - REF(下,1)) 》 0)) AND CROSS(MACD,0)) AND (MACD 》= 0)) AND (DIF 》 0)) AND (((HH - REF(HH,1)) 》 0) AND (VOL 》 REF(VOL,1)))));

  DRAWTEXT((((BB 》= 0.7) AND (CLOSE 《 上)) AND ((下 - REF(下,1)) 》 0)),0.7,‘。量价配合完美’),color00FF00;

  DRAWTEXT((((BB 》= 0.7) AND (CLOSE 《 上)) AND ((下 - REF(下,1)) 》 0)),0.7,‘。(追)’),color0000FF;

  N15HIGH:=REF(HIGH,15);

  N1LOW:=REF(LOW,1);

  FF:=(((N15HIGH - N1LOW) / N1LOW) 》 0.15);

  DRAWICON((((((CROSS(MA(CLOSE,P1),MA(CLOSE,P2)) 》 0) AND (((N15HIGH - N1LOW) / N1LOW) 《 0.15)) AND (OPEN 》= MA(CLOSE,P1))) AND (CLOSE 》= MA(CLOSE,P1))) AND (LOW 《= MA(CLOSE,P1))),0.5,1);

  DRAWTEXT((((((CROSS(MA(CLOSE,P1),MA(CLOSE,P2)) 》 0) AND (((N15HIGH - N1LOW) / N1LOW) 《 0.15)) AND (OPEN 》= MA(CLOSE,P1))) AND (CLOSE 》= MA(CLOSE,P1))) AND (LOW 《= MA(CLOSE,P1))),0.5,‘★^回头望月’),colorFF0000;

  VAR10:=(((CLOSE - MA(CLOSE,58)) / MA(CLOSE,58)) * 100);

  VAR11:=((((VAR10 》 (1 * REF(VAR10,1))) AND (VAR10 《 K)) AND (VAR10 》 G)) * 1.5);

  VAR12:=((VOL / CAPITAL) * 100);

  VAR13:=LLVBARS(LOW,50);

  VAR14:=SUM(VOL,VAR13);

  VAR15:=HHVBARS(HIGH,50);

  VAR16:=SUM(VOL,VAR15);

  VAR17:=(((CLOSE - REF(OPEN,VAR15)) / REF(OPEN,VAR15)) * 100);

  VAR18:=((VAR16 / CAPITAL) * 100);

  VAR19:=(((CLOSE - REF(OPEN,VAR13)) / REF(OPEN,VAR13)) * 100);

  VAR20:=((VAR14 / CAPITAL) * 100);

  VAR21:=MA(CLOSE,3);

  VAR22:=(REF(CLOSE,2) * 0.865);

  VAR23:=(REF(CLOSE,13) * 0.772);

  VAR24:=MIN(VAR22,VAR23);

  VAR25:=MA(CLOSE,13);

  抄底1:(IF((((((CLOSE - VAR24) / CLOSE) 《 0.03) AND (VAR17 《 (-35))) AND ((SUM(VAR12,5) / 5) 《 1.8)),1,0) * 0.4),LINETHICK3,colorFF0000;

  DRAWTEXT((抄底1 》 0),抄底1,‘★抄底’),LINETHICK3,colorFFFFFF;

  DRAWTEXT((抄底1 》 0),抄底1,‘成功90%’),LINETHICK3,color00FF00;

  VAR266:=(((CLOSE - REF(CLOSE,1)) / REF(CLOSE,1)) * 100);

  VAR277:=((EMA(CLOSE,12) - EMA(CLOSE,26)) * 100);

  VAR288:=EMA(VAR277,9);

  VAR299:=(2 * (VAR277 - VAR288));

  DRAWTEXT((((VAR277 《 (-50)) AND (VAR266 》 7)) AND (VAR277 《 VAR288)),(-0.08),‘★’),colorFFFFFF;

  DRAWTEXT((((VAR277 《 (-50)) AND (VAR266 》 7)) AND (VAR277 》= VAR288)),(-0.1),‘● ’),colorFFFFFF;

  VAC:=(LOW * 0.9);

  VAB:=EMA(LLV(LOW,90),21);

  VAD:=(((VAC * VOL) + (VAB * (CAPITAL - VOL))) / CAPITAL);

  VAE:=EMA(VAD,30);

  VAF:=(CLOSE - REF(CLOSE,1));

  VA10:=MAX(VAF,0);

  VA11:=ABS(VAF);

  VA12:=((SMA(VA10,7,1) / SMA(VA11,7,1)) * 100);

  VA13:=((SMA(VA10,13,1) / SMA(VA11,13,1)) * 100);

  VA14:=((SMA(MAX(VAF,0),6,1) / SMA(ABS(VAF),6,1)) * 100);

  VA15:=((((-200) * (HHV(HIGH,60) - CLOSE)) / (HHV(HIGH,60) - LLV(LOW,60))) + 100);

  VA16:=(((CLOSE - LLV(LOW,15)) / (HHV(HIGH,15) - LLV(LOW,15))) * 100);

  VA17:=SMA(((SMA(VA16,4,1) - 50) * 2),3,1);

  VA18:=(((INDEXC - LLV(INDEXL,14)) / (HHV(INDEXH,14) - LLV(INDEXL,14))) * 100);

  VA19:=SMA(VA18,4,1);

  VA1A:=SMA(VA19,3,1);

  VA1B:=(((HHV(HIGH,30) - CLOSE) / CLOSE) * 100);

  VA1C:=((((((((VA14 《= 25) AND (VA15 《 (-95))) AND (VA1B 》 20)) AND (VA17 《 (-30))) AND (VA1A 《 30)) AND ((VAE - CLOSE) 》= (-0.25))) AND (VA12 《 22)) AND (VA13 《 28));

  低买1:=STICKLINE(VA1C,0,0.1,1,1);

  发射:STICKLINE(VA1C,0,0.7,2,0),LINETHICK2,color0000FF;

  DRAWTEXT((VA1C 》 0),0.7,‘^★发射’),colorFFFFFF;

  A4:=BARSLAST(ref(cross(dif,dea),1));

  B1:=ref(c,A4+1)》c and ref(dif,A4+1)《dif and cross(dif,dea);

  DRAWTEXT(FILTER(B1》0,5),dif+0.2,‘●背离’),COLORyellow;

  STICKLINE(MACD《ref(MACD,1)and MACD》0,0,MACD,2,0),colorgreen;

  STICKLINE(MACD《ref(MACD,1)and MACD《0,0,MACD,2,0),colorFFCC33;

  STICKLINE(MACD》ref(MACD,1)and MACD,0,MACD,2,0),COLORyellow;

  STICKLINE(MACD》ref(MACD,1)and MACD》0,0,MACD,2,0),COLOR8899ee;

  if(dif《0,dif,0),coloryellow,linethick2;

  if(dif《0,0,dif),colorred,linethick2;

  if(dif《dea,dif,dea),COLORWHITE,linethick2;

  if(dif》dea,dea,dea),{COLORgreen}colorFF937F,linethick2;

  缩头:=IF(MACD》0 AND REF(MACD,1)》REF(MACD,2) AND MACD《 REF(MACD,1),1,0);

  缩脚:=IF(MACD《0 AND REF(MACD,1)《 REF(MACD,2) AND MACD》REF(MACD,1),1,0);

  阻力:=IF(CROSS(C,MA(C,20)) OR CROSS(C,MA(C,60)),1,0);

  支撑:=IF(CROSS(MA(C,20),C) OR CROSS(MA(C,60),C),1,0);

  做多:=IF(CROSS(MACD,DIF) AND DIF》0 AND MACD》0,1,0);

  放空:=IF(CROSS(DIF,MACD) AND DIF《0 AND MACD《0,1,0);

  DRAWTEXT(FILTER(缩头,3) AND 缩头,MACD,‘▼’),COLORFF00FF;

  DRAWTEXT(FILTER(缩头,3) AND 缩头,MACD+0.2,‘缩头’),COLORFF00FF;

  DRAWTEXT(FILTER(缩脚,3) AND 缩脚,MACD,‘△’),COLOR00FF00;

  DRAWTEXT(FILTER(缩脚,3) AND 缩脚,MACD-0.2,‘缩脚’),COLOR00FF00;

  DRAWTEXT(FILTER(阻力,16) AND MACD》=0,MACD+0.01,‘¤阻力’),COLOR00FFFF;

  DRAWTEXT(FILTER(支撑,16) AND MACD《0,MACD,‘¤支撑’),COLORFFFFFF;

  多头趋势:=IF(DIF》=0 AND MACD》=0 OR (DIF《0 AND MACD》=0),1,0);

  空头趋势:=DIF《0 AND MACD《0 OR (DIF》=0 AND MACD《0);

  up:=FILTER(多头趋势,13);

  DRAWTEXT(up,DIF,‘¤多头’),COLORRED;

  pu :=FILTER(空头趋势,13);

  DRAWTEXT(PU,DIF,‘¤空头’),COLORFF8800;

  低位金叉:=CROSS(DIF,DEA) AND DIF《-0.1;

  STICKLINE(低位金叉,0,0.08,6,0),COLORYELLOW;

  DRAWTEXT(低位金叉,低位金叉-1.5,‘ 低位金叉’),COLORWHITE;

  JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA》=0));

  二次金叉:=CROSS(DIF,DEA) AND DEA《0 AND COUNT(JCCOUNT=2,21)=1;

  STICKLINE(二次金叉,0,0.06,6,0),ColorFF00FF;

  DRAWICON(二次金叉,dea*1.04,1) ;

  DRAWTEXT(二次金叉,0.5,‘ 二次金叉’),ColorYELLOW;

  A1:=BARSLAST(REF(CROSS(DIF,DEA),1));

  底背离:=REF(CLOSE,A1+1)》CLOSE AND DIF》REF(DIF,A1+1) AND CROSS(DIF,DEA);

  STICKLINE(底背离,0,0.03,6,0),Color00FF00;

  DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,linethick1;

  DRAWTEXT(底背离,0.12,‘ 底背离’),ColorFF00FF;

  A2:=BARSLAST(REF(CROSS(DEA,DIF),1));

  顶背离:=REF(CLOSE,A2+1)《CLOSE AND REF(DIF,A2+1)》DIF AND CROSS(DEA,DIF);

  DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,linethick1;

  DRAWTEXT(顶背离,0.2,‘ ★顶背离’),ColorYELLOW;

  设置{SHORT=26,LONG=12,M=9,P1=19,P2=120,K= -40,G=-26}

  更多股票公式:优化MACD精确控盘的相关信息请关注金投股票网。

万2开户
(赠送炒股公式)
免责申明: 1、本站涉及的内容仅供参考,不作为投资依据,依此操作风险自担。
2、本站部分内容转载自网络,如有侵权请联系QQ9446379删除。
index.xml index1.xml index2.xml index3.xml index4.xml news.xml site.xml ticai.xml 股票公式:优化MACD精确控盘,股票知识,股票入门,炒股入门